首頁 | 關于我們 |  服務項目新聞動態 | 資料下載 |  技術支持 | 知識庫 | 聯系我們 報修電話:13821136568
 
   天津電腦維修網 > 知識庫 > 網絡相關知識 > 正文
 
設置cisco路由器通過ADSL上網
 
說明:此案例為天津聯通adsl pppoe接入,需要使用一個普通adsl modem和一臺cisco 2500路由器(雙以太口),ios12.2(15)t,能夠實現局域網共享上網
  此案例配置共分7步:
  第一步:配置vpdn
  vpdn enable # 啟用路由器的虛擬專用撥號網絡---vpnd
  vpdn-group office # 建立一個vpdn組
  request-dialin # 初始化一個vpnd tunnel,建立一個請求撥入的vpdn子組
  protocol pppoe # vpdn子組使用pppoe建立會話隧道
  第二步: 配置路由器連接adsl modem的接口
  interface ethernet1
  no ip address
  pppoe enable # 允許以太接口運行pppoe
  pppoe-client dial-pool-number 1 # 將以太接口的pppoe撥號客戶端加入撥號池1
  第三步:配置邏輯撥號接口:
  interface dialer1
  ip address negotiated # 從adsl服務商動態協商得到ip地址
  ip nat outside # 為該接口啟用nat
  encapsulation ppp # 為該接口封裝ppp協議
  dialer pool 1 # 該接口使用1號撥號池進行撥號
  ppp authentication pap callin # 啟用ppp pap驗證
  ppp pap sent-username xxxxxxx password 0 yyyyyyy # 使用已經申請的用戶名和口令
  第四步:配置內部網絡接口
  interface ethernet0(內部網絡接口)
  ip address 10.1.1.1 255.255.255.0
  ip nat inside # 為該接口啟用nat
  第五步:配置路由器為內部網絡主機提供dhcp服務
  ip dhcp excluded-address 10.1.1.1
  ip dhcp pool abc
  import all(導入dns和wins server)
  network 10.1.1.0 255.255.255.0
  default-router 10.1.1.1
  第六步:配置nat:
  access-list 1 permit 10.1.1.0 0.0.0.255
  ip nat inside source list 1 interface dialer1 overload
  第七步:配置缺省路由
  ip route 0.0.0.0 0.0.0.0 dialer1
2010-8-5 8:21:56
江苏时时彩